SAP Knowledge Base Article - Public

2344185 - Enabling "Date of Birth" field in Personal information portlet is not saving and will show blank

Symptom

  • Enabling existing "Date of Birth" field (set to visibility=Both) in Personal information portlet allows you to fill in the date and save it, but it will always show up blank in Personal Information portlet.

Environment

  • SAP SuccessFactors HCM Suite
  • Employee Central

Reproducing the Issue

  1. Log into instance and open "Manage Business Configuration" tool within Admin Center.
  2. Go to "personal Information" section and enable "date of Birth" field.
  3. Save this change and go to RBP to set permissions on the new enabled field.
  4. Now go into "personal information" section of an employee and set a date to this field that is now visible.
  5. You able to successfully save the field, but you notice the field shows up blank.

Cause

  • Personal Information Date of Birth field can no longer be used and is set to disabled (not visible) on purpose. This field is part of the Biographical Information portlet now.

Resolution

  • Use the Date of Birth field within Biographical Information portlet.
  • Another option could be to create a custom-date field and name that date of birth within personal information portlet (If the need is to have this field specifically within personal information portlet).

Please note that this article also applies to the "country of birth" field and not only to "date of Birth" field.

Keywords

JIRA ECT-4569 , KBA , LOD-SF-EC-PER-PRS , Personal Info - Config, Rules, RBP, UI , Problem

Product

SAP SuccessFactors HCM Core 1511 ; SAP SuccessFactors HCM Core 1602 ; SAP SuccessFactors HCM Core 1605