SAP Knowledge Base Article - Public

2344918 - Pre-requisites for Rating Scale configuration in Dashboard 2.0

Symptom

Rating scale configuration not referenced correctly in DB 2.0

Reproducing the Issue

  1. Navigate to DB 1.0 and select the required PM form and run the dashboard, notice that the Overall Rating Distribution pulls in the rating labels and not the associated values.
  2. Navigate to DB 2.0 and run the Standard Performance Dashboard, you’ll notice based on the Rating scale configuration the values are pulled up and not the labels unlike in DB 1.0.

Cause

Rating scale configuration has not been setup correctly. The reason it seems to be working fine in Dashboard 1.0 is that there it seems to be taking the labels instead of the scores as per the Rating scale.

For example, in the customer’s instance the rating scale was set as [9,91,92,93] which isn’t ideal.

Score            Label

9                   Needs improvement

91                 Meets Expectations

92                 Successful performance 

93                  Exceeds Expectations

 

Now in the performance form you selected ratings for 4 objectives like  Needs Improvement, Successful Performance, Meets expectations and Exceeds Expectations. Now the Overall Performance rating is calculated as (9 + 91 + 92 + 93)/4 = 71.25 (Just an example actual PM calculation differs). As the Overall rating is 71.25, it will try to fit the user under “Meets expectations”. If the Overall rating is something around 9, it will try to fit under “Needs Improvement”.

Please note that while configuring rating scales there should always be a common difference amongst the rating scores. For example [90,91,92,93,94] or[9, 91,173,255,..]. The scores upon normalization will always land up below 91 for users with score [91,92,93] and hence they will get consolidated under 91 in the Dashboard and not set the desired output as opposed to pulling from labels instead of scores which will always give the right output. The minimum rating although stays unaffected. 

Resolution

The possible workaround for this would be to build a Custom dashboard including the new standard tiles from Success Store.

Secondly, Rating scale configuration should always be made in such a way that there should be always a common difference amongst the scores. For example, [1,2,3,4,5] or [91,92,93,94,95]. In both these cases we observe that the common difference between the scores is 1 and this is a mandatory pre-requisite for the configuration of the same.

Keywords

Dashboard 2.0, Rating Scale , KBA , LOD-SF-ANA-DSH , YouCalc Dashboards and Tiles (Dashboards 2.0) , Problem

Product

SAP SuccessFactors Workforce Analytics all versions