SAP Knowledge Base Article - Public

2345774 - Absence Doesn't Disappear After Cancelation

Symptom

When you submit an absence [time off request] but decide to cancel this an error is displayed

An application error occurred. Please try again later, or notify support (with the error information of errorID=XXXXX, timestamp=XXXXX, and the version information from the current screen) if the issue keeps occurring. [object Object]

Environment

SAP Successfactors Employee Central Time Off

Reproducing the Issue

  1. Go to Employee Files
  2. Select Time Off
  3. Submit an absence request [you will see this absence showing under my requests]
  4. Click to Cancel this request

cancelreq.jpg

You would expect this request to disappear from the UI however it displays as pending and remains on the list and an application error is raised by the system

An application error occurred. Please try again later, or notify support

Cause

Check your EmployeeTime object, there is a field called pendingData this is most probably set to yes and this should be set to no.

For objects: Employee Time and Employee Time Sheet this field should always be set to No.

Resolution

  1. Go to Admin Center
  2. Select Configure Object Definition
  3. Search for the object "Employee Time".
  4. Make Correction and set the value of "Pending Data" to "NO".
  5. Save.
  6. Search for the object "Employee Time Sheet".
  7. Make Correction and set the value of "Pending Data" to "NO".
  8. Save.

Keywords

Leave Cancellation, Time Off, application error , KBA , LOD-SF-EC-TIM , Time Off , Problem

Product

SAP SuccessFactors Employee Central all versions