SAP Knowledge Base Article - Public

2347226 - Employee Central - Document Generation

Symptom

This is a collection of useful articles related to Document Generation.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental. 

Environment

  • SAP SuccessFactors HXM Suite
  • SAP SuccessFactors Employee Central

Reproducing the Issue

IssueIdentified_blue_small.jpgHandbook_orange_small.jpgTips_blue_small.jpgIncident_blue_small.jpg

Before opening an case with Product Support, please be sure that before you open a support case with Product Support, you have performed the following sanity checks on your configuration/data - bearing in mind most issues are due to a configuration issue:

  • The feature is correctly enabled, as described in the related Implementation Guide
  • Correct permissions are granted to the administrator/end-user to be able to use the tool (as specified in the Implementation Guide)
  • Has the configuration changed recently?
    • Was it working before the recent changes?
    • Can the recent change be undone so re-testing can be performed?
  • Can the issue be reproduced for just 1 or multiple admins?
    • If the issue is reproducible for all it is still likely to be a permissions issue.
    • If it seems to be related to 1 or a small admin population - the next step is to check and verify the permissions are correctly granted.
  • Is the data correct? (Ensure that any recent configuration changes you have made have not caused any data inconsistencies)
  • Have you verified that, according to the related Implementation Guide, the feature is configured according to Best Practices recommended in the handbook?

 

 

Cause

IssueIdentified_blue_small.jpg Handbook_blue_small.jpg Tips_orange_small.jpg Incident_blue_small.jpg

Tips & Tricks

Below are some tips and tricks recommended by Product Support, which you should consider first before opening a Support case

FAQ Index

Common Implementation Issues

Most Document Generation implementation issues are caused by either skipping steps mentioned in the Implementation Handbooks (found here) or trying to configure in a way that is not supported.

Frequently Encountered Issues

How To

  • 2235340 - How to enable Employee Central Document Generation feature
  • 2323580 - Document Generation: Change or Hide or Add Filters
  • 2346020 - Document Generation: Relationship Type
  • 2343666 - Document Generation - Special Characters not converted correctly when generating word doc
  • 2295288 - Document Generation: Specific employees are unable to see the "Document Generation" related tools in Admin Center although permissions for it have been set correctly.
  • 2387814- Document Generation - How to map Pay Component data to a Document Template
  • 2666252 - Can email templates created in document generation be used for EC Alerts?

 

Configuration Issues

Most error occured due to invalid configuration. A lot of the time it is due to a Business Rule causing the issue or a step has been missed in the

  • 2344607 - Document Generation: Uploaded image does not displayed in generated document
  • 2465399 - Document Generation: Image/Logo is not displayed while generating documents in word
  • 2250862 - Document Generation: Error - No screen exists
  • 2320253 - Document Generation: Specific field is not available for direct mapping
  • 2310843 - Document Generation: Unable to 'Generate Document' as Self Service (MSS/ESS)
  • 2341359 - Document Generation: Rule type is not displayed when trying to create a new rule to be used for document generation mapping

 

Instance Synchronization

Since 1805, the "auto-number" fields in MDF can no longer be manually set. Therefore, you need to follow the solution documented in this article to manually Export and then Import the Documents from one instance to another.

  • 2716682 - Instance Sync: Document Generation Sync completed with errors

 

 SAPONELAUNCHPAD.jpg

 You should also check the SAP for Me for any new Knowledge Articles that are not included in the above list

 

ToTop.png

 

Resolution

IssueIdentified_blue_small.jpg Handbook_blue_small.jpg Tips_blue_small.jpg Incident_orange_small.jpg

When opening a support case, please ensure the following information is attached to the case

  • Screenshot of the Error Message - also copy/paste the content of the error message to the case if possible (for JAVA errors or errorIds)
  • Timestamp - Copy/paste the text from the "Show version information" pop-up into the case
  • Is the issue replicable for all users or just some/one?
  • Screenshots of granted users Role-Based Permissions settings (if relevant)
  • Screenshots of Business Rules
  • Screenshots of UI configurations
  • Please provide detailed steps to reproduce the issue you are encountering - preferably including screenshots - Please make sure that the screenshot is full screen (meaning to show complete web page view)
  • When creating an issue, please answer following questions (answer whichever is applicable, if a question doesn't apply in a scenario then answer "Not Applicable"):
    • Did this issue start recently?
    • Was the same feature or functionality working before?
    • Is the issue reproducible for other users?
    • If the issue is related to a Picklist or Object field, then please attach an export of the Picklist/Object data

 

ToTop.png

Keywords

Document Generation, Implementation Tips, Employee Central, workflow, FAQ , KBA , LOD-SF-EC-DOC , Document Generation , LOD-SF-EC , Employee Central , How To

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM all versions