Symptom
ORD reports transferred from one instance to another do not work as expected in the destination instance:
- Completely Fail to run
or - Fields and / or filters incorrectly mapped
Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
- Download Reports from Instance A using the Report Transfer Option.
- Upload the reports to Instance B using the same option.
- Previewing the report will display a rendering error or an Application Error
[Error rendering List Report component] - Editing the report will also result in strange behaviours.
- Validating the report will expose the underlying issue(s)
- Report Transfer / Report Definition: How to download and/or Upload xml files
Cause
Reports transferred between instances will work only if both instances have the exact configuration for the fields and tables used in the reports.
Resolution
Reports transferred between instances will work only when both the instances have the exact configuration for the fields and tables used in the reports.
The ideal way to design reports in one instance, with the intent of copying it to the another instance later, would be to do instance refresh from Prod to Test before you start.
However, if the reports have already been transferred, we recommend the below:
- Validate the affected report(s) in the Destination instance and identify the fields/tables/joins with issues.
- Compare the configuration for these, between the Source and the Destination instances.
- Ensure that the configuration in the Source instance matches the ones in the Destination instance.
If the report maps incorrect / different fields, you could just remove the undesired fields and add the desired ones.
Keywords
Report, Validation, Error, Application , Rendering, List, component, Download, Import, Export, Online, Designer, Advanced, canvas , KBA , LOD-SF-ANA-ORD , Online Report Designer , LOD-SF-ANA-ADV , Advanced Reporting (ODS) , LOD-SF-ANA-RCT , Report Centre , Problem