SAP Knowledge Base Article - Public

2348200 - Hire/Rehire: Can't Navigate to the Compensation Information Page in the Add New Employee Wizard (People Profile/PP3)

Symptom

When using People Profile (PP3),You would receive an application error while hiring a New Employee

The application error id would be accompanied by the fingerprint id =

  • 6781c37bae02371922433581e75d685f8cd3d088
  • 8cd44224c4f3d4b55e598b47c09918a9c1cff033 
  • Getting an application error without a fingerprint or error id

When running the Check Tool check "PaymentInformationScreenLookUp" the result returned an error.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental

Environment

  • SAP SuccessFactors Employee Central - Add New Employee
  • SAP SuccessFactors Employee Central - Payment Information

Reproducing the Issue

  1. With People Profile (PP3) enabled, go to the Add New Employee Wizard,
  2. Fill out all required fields.
  3. On the Job Information page, click 'Continue'.
  4. The page will reload, but will not navigate to the Compensation Information page.

Cause

Configuration Issue - The Configuration UI for Payment Information Portlet's was not specified in 'Personal Information Screen Lookup' in Manage Data.

2UI.png

Resolution

Please refer to the Implementing and Configuring Payment Information in Employee Central handbook for complete guidance in implementing this feature.

Please make sure that the following 2 options are enabled in Provisioning (if you don't have access to Provisioning, you may reach out to your implementation partner or SAP Cloud Product Support):

  • Enable Payment Method in Payment Information even if Payroll Integration is not enabled
  • Enable new Payment Information (MDF-based, effective-dated, and employment-specific)

If these are enabled, to correct the configuration issue, you first need to decide on the following:

Would you like to see the Payment Information UI in the Hire/Rehire Wizards:

No - you do not want to utilize the Payment Information UI in the Hire/Rehire Wizard:

  1. Go to Admin Centre. In the Tool Search field, enter Manage Data.
  2. In the Create New dropdown menu, select Personal Information Screen Lookup.
  3. Select Take Action and Permanently Delete Entry.

The Payment Information UI will be displayed in the Add New employee wizard, when you configure the Payment Information UI in Personal Information Screen Lookup

  • 2409336 - PP3 - Payment Information UI not working the same in Add New Employee

Yes - you do  want to utilize the Payment Information UI in the Hire/Rehire Wizard:

Step 1:

  1. Navigate to "Configure People Profile" in Admin Centre.
  2. Select the Payment Information block
  3. View MDF screen ID:
  4. Example here: 1705+_Payment_Information_Portlet

4UI.png

 

Step 2:

  1. Go to Admin Centre. In the Tool Search field, enter Manage Data.
  2. In the Create New dropdown menu, select Personal Information Screen Lookup.
  3. Enter the relevant information.
      ○ Object Type > Select Payment Information in the dropdown menu.
      ○ screenID > Select a configuration UI. 
  4. Click Save.

3UI.png

 

The above information is also explained in the Implementing and Configuring Payment Information in Employee Central handbook under the section "Setting Up Payment Information" > "Setting Up the Configuration UI".


Getting an application error without a fingerprint or error id when navigating to Compensation Information in Add New Employee wizard: The error may also appear if some UI rule was used in the UI, but later deleted leaving a blank spot for the rule. To detect and rectify this, do the following:

  1. Go to Admin Center
  2. Search for Manage Data
  3. Search for Personal Information Screen Lookup and select the value of the next drop-down. Copy the ScreenID
  4. In a new tab, go to Admin Center and search for "Manage Configuration UI"
  5. Search  for the ID you copied from previous screen
  6. Search  for the option Edit Properties (this appears when you hover over Payment Information on the left-side of the screen)
    EditProperties.jpg
  7. Check all the sections onInitUI, onInsertUI and onLoad rules and see if there is some space where a rule was supposed to be saved but there is not any value, example:
    EmptySlotRule.jpg
    Note: The rule can also be in one of the fields of the portlet so you need to check all the fields as well.
  8. Remove that space by selecting the trash Icon and then select OK.
  9. Save the changes
  10. Review all the onchange rules by selecting the pencil Icon next to every field.

See Also

2264212 - How to add Payment Information section to People Profile 3

Keywords

Add New Employee, Compensation Information, Job Information, Payment Information, PP3, People Profile , MDF screen ID, fingerprint=6781c37bae02371922433581e75d685f8cd3d088, 6781c37bae02371922433581e75d685f8cd3d088, 8cd44224c4f3d4b55e598b47c09918a9c1cff033, error, PersonalInformationConfigUIScreenLookup.getScreenId(), PaymentInformationScreenLookUp, Empty Rule , KBA , LOD-SF-EC-PAY , Payment Information (Bank Information) , LOD-SF-EC , Employee Central , LOD-SF-EC-HIR , Hire & Rehire Wizards , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions