SAP Knowledge Base Article - Public

2348700 - Workflow configuration must be case sensitive

Symptom

The workflow is not being called even when it is configured in the Admin Center -> Manage Organization, Pay and Job Structure -> Workflow and Workflow Derivation XML.

Environment

SAP SuccessFactors: Employee Central

Reproducing the Issue

Pre-requisite:

  1. Go to Admin Center -> Manage Organization, Pay and Job Structure -> Workflow and set up a workflow with the Workflow ID = "TEST"
  2. Configure the workflow-rules XML via Provisioning and specify the workflow id to  <trueoutput>Test</trueoutput>

Steps to Reproduce:

  1. Log into the Employee Central instance
  2. Navigate to "My Employee File"
  3. Select a user, or use the current logged in user
  4. Navigate to the portlet which has a workflow defined as per the pre-requisite
  5. Invoke the workflow based on the workflow rules

Actual Result: Workflow is not invoked

Expected Result: Workflow is invoked

Cause

When configuring the workflow ID's in both the Admin Tools and in the Workflow Rules XML, the workflow ID must be case sensitive.

Resolution

Ensure that the workflow id's are case sensitive when configuring workflows. In this example, the workflow ID needs to be changed to be the same case TEST in both configuration areas.

Keywords

workflow, xml, case sensitive, workflow-rules.xml, trueoutput, workflowid, id, workflow-id, workflow ID, rule, case, capital, lower, jobinfo, compinfo  , KBA , LOD-SF-EC , Employee Central , Problem

Product

SAP SuccessFactors HCM Core 1605