Symptom
If the user has no right to create a new account, it is not possible to convert a lead into an opportunity.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
- Go to the Sales work center .
- Select the Leads view.
- Open Lead ABC (ABC represents the ID of the Lead).
- Click on the Actions button.
The option Convert to Opportunity is inactive for the logged in user.
Cause
This is the expected system behavior if the Business Role the user is assigned to has the Business Action Restriction Create Account: Disabled.
During then conversion to an opportunity, an active account is created and by restriction, this is not allowed. Hence, the option is disabled.
Resolution
If a lead is created with an active account, the user needs to create a follow-up opportunity. The conversion is specifically for inactive leads.
Keywords
Leads, Opportunity, Conversion, business action, restriction , KBA , opportunity , leads , conversion , LOD-LE-CQP-CO , Lean Sales Orders , LOD-CRM-OPP , Opportunity Management , How To