Symptom
- Unable to fill in valid IRD numbers for New Zealand National ID.
- Instance will always give error: Please enter a valid National ID of this type: Inland Revenue Department Number for New Zealand.
Environment
SAP Successfactors Employee Central
Reproducing the Issue
- Log into your instance.
- Either add a new hire or update existing personal information section.
- add National ID for New Zealand.
- select "Inland Revenue Department Number" for Card type.
- Add a correct number and try to go to next page or save changes.
- The error is received allthough number is correct.
Cause
- The issue is related due to the fact that there was a recent change to the IRD formula which validates if the number is a correct IRD number.
- Currently the backend algorithm has not been adjusted yet within the succesfactors system.
Resolution
- The backend algorithm has been targetted to be fixed in version 1608
- In the interim you can temporarilly turn off "enable national ID validations" within "Company System and Logo Settings".
Keywords
JIRA ECT-56612 , KBA , LOD-SF-EC-PER-NAT , National ID - Config, Rules, RBP, UI , Problem
Product
SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions