Symptom
- Running Ad Hoc reports online results in a blank screen after a certain period of time. (5 minutes in most cases)
- Running Ad Hoc reports online results in "org.eclipse.birt.report.service.api.ReportServiceException: Failed to open the document."
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors HXM Suite
Reproducing the Issue
- Navigate to the Reporting / Analytics.
- Choose 'Ad Hoc Reports'.
- Select the report under concern and click 'Run Report'.
- Choose 'Run Online' and 'Generate Report'.
- The system displays a screen with the text 'Processing, please wait ...' for a few minutes and then a blank screen.
Cause
The blank screen or the Org exception Birt error is a result of a time out caused.
The Timeout for Ad Hoc online run is 5 minutes.
Resolution
The behavior is expected.
- As a general rule of thumb, use the 'Run Offline' option for all Ad Hoc reports that take a couple of minutes to run.
- This will queue the report run in our job servers and it will be completed in the background.
- Once done, the output can be downloaded from the 'Scheduled Reports' page.
- If you have the Report Center, it will be available under "View Schedules":
- While this ensures a successful completion, unlike the 'Run Online' option, the 'Run Offline' option allows you to use SuccessFactors while the report is still running in the background. The timeout cannot be modified.
See Also
KB article 2219570 - Ad Hoc Reports Error when Running the report Online or Exporting to Excel
Keywords
sf, success factors, RPT, adhoc, not responding, unresponsive, stop , KBA , LOD-SF-ANA-ADH , Adhoc Reports & Report Builder , Problem
Product
SAP SuccessFactors HXM Suite all versions