SAP Knowledge Base Article - Public

2350486 - Search with Extension Field does not Work

Symptom

Extension fields added to the Advanced search do not fetch any records.

Reproducing the Issue

  1. Go to the work center with the extension field and open the OWL (Object Work List).
  2. In the OWL screen, click on the Advanced filter option.
  3. Enter Search data within the extension field.
  4. Click on Go.

           No records will be found.

Cause

This normally happens when there is a mismatch in the Extension field's Business context and the Business Object where the field is assigned.

Example 1: In the Product OWL: While creating/adding an extension field, 2 contexts are found.

  • Material - Sales Information
  • Material – General Information

Products_view.PNG

 

Example 2: In the Account OWL: While creating/adding an extension field, 2 contexts are found.

  • Account - General Information
  • Primary Contact Extensibility

Accounts_view.PNG

Resolution

  1. Hide the added field via Key User Tool.
  2. Add a new Extension field using the correct Business context.
  3. Example: If the field is used within the Account view, then the field with the context Account-General Information should be added. If the field has to be used within the Contacts view then the Primary Contact Extensibility should be used. Sample screen as below:

 Selection_to_be_made.PNG

Keywords

KBA , BC-DWB-REP-EXT , Extensibility , Product Enhancement

Product

SAP Business ByDesign all versions ; SAP Cloud for Customer add-ins all versions