Symptom
During the Basic Configuration in transaction SOLMAN_SETUP, in step Configure CA Introscope, the system reports that it is offline with the following error being raised in the defaultTrace of the Solution Manager:
com.sap.smd.introscope.em.rest.EmRestGateway.test
Text Error accessing to Enterprise Manager: <host>@<port>
[EXCEPTION]
com.sap.smd.introscope.em.IntroscopeException: http status code 403
at com.sap.smd.introscope.em.rest.IntroscopeHttpConnection.executeQuery(IntroscopeHttpConnection.java:152)
at com.sap.smd.introscope.em.PooledConnection.executeQuery(PooledConnection.java:26)
at com.sap.smd.introscope.em.rest.EmRestGateway.performStatusQuery(EmRestGateway.java:80)
at com.sap.smd.introscope.em.rest.EmRestGateway.test(EmRestGateway.java:45)
at com.sap.sup.admin.wily.jdbc.EMInfo.test(EMInfo.java:387)
at com.sap.sup.admin.wily.jdbc.EMOverview.populateEmInfo(EMOverview.java:433)
Environment
- SAP Solution Manager 7.x.
- CA Introscope Enterprise Manager 9.x.
Reproducing the Issue
- Open transaction SOLMAN_SETUP.
- Choose Basic Configuration.
- Go to step 3 - Configure CA Introscope.
Cause
This connection is checked via a direct connection to the Introscope Enterprise Manager, which you can check in the SAP Netweaver Java Administration > Configuration > Destinations:
In the example above, there are two connections, because SSL is configured. By checking field "URL", we find a port, which is the port that will be used for checking the connection, in this case, port 8444.
The cause of this issue can be because this port is already being used by another application in the operational system level.
Resolution
- Stop the Enterprise Manager.
- In the OS level, execute the following command:
netstat -ano | findstr <port>
In this case, <port> is 8444. - If any result is shown, it is because this port is already being used by another application.
- To change the port used by the EM, change property introscope.enterprisemanager.webserver.port in file <EM Installation folder>/conf/IntroscopeEnterpriseManager.properties .
- Restart the EM and perform step Configure CA Introscope again.
Keywords
KBA , SV-SMG-DIA-WLY , Solution Manager / Introscope Integration , XX-PART-WILY , Introscope by CA Technologies , Problem