Symptom
Addresses can not be entered for people in Canada.
When entering a Canada Address, country specific address fields and saving we are getting error message.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Employee central
Reproducing the Issue
Add a new address
Saving it gives an error
Cause
Script error is shown
Resolution
There are 2 possible cause for this issue:
1. Please check the picklist in the CSF SDM XML for field 'State/Province' for 'Canada' country and it should be exactly 'PROVINCE_CAN'.
2. The if the above is correct please check the values. Download picklist export from admin center--> Piclist management.
The 'External Code' column for PROVINCE_CAN picklist, check if it has been left blank. If so please download a standard release picklist from successstore and correct it accordingly.
Keywords
canada address canada country address error , KBA , LOD-SF-EC-PER-ADR , Home Adress - Config, Rules, RBP, UI , LOD-SF-EC-JOB-CSF , Country Specific Configurations , Problem