Symptom
When you are migrating Customers to enhance Business Partner with Acccount role through migration, system throws below error message:
Update not possible; specified data for CUSTOMER with key INTERNAL_ID = XXXX does not exist
Reproducing the Issue
1. Go to Business Configuration work center
2. Select Implementation Projects view or Overview.
3. Search and Open the migration activity Migration of Customers
4. Execute Migration for the respective Migration File
Cause
You are trying to update Business Partner with role Account and it is not possible through Migration of Customers
Resolution
You can manually update Business Partner as role Account by following the below steps
1. Go to Business Partner Data work center
2. Select Business Partner view
3. Select any Business Partner
4. Select Create As
5. Select Account
Keywords
KBA , migration , customer , update not possible , SRD-CC-MIG-CNT , Migration: Content , How To