Symptom
Access restriction for the Social Media Messages and Templates is not working.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Administrator work center.
- Go to the Business Roles view.
- Search and open the business role ABC (ABC represents the ID of the business role).
- Go to the Access Restriction tab.
- Enable No Write Access for below views:
- SEOD_SMA_SADL_WCVIEW (Social Media Messages)
- COD_SEOD_TEMPLATE_WCVIEW (Service Templates)
- COD_SALES_WCF (Sales Templates)
- Login to the UI with a user assigned to the Business Role ABC.
- Go to the Service work center.
- Go to the Social Media Messages view.
- User can still create and save a New Social Media Message.
- The same is applicable for the Template view (both in the Service and in the Sales workcenter).
Cause
Currently we do not support access restriction for the Social Media Messages and Templates functionality.
Resolution
This is the expected behavior of SAP Cloud for Customer.
Keywords
templates, email, social media, write access, access restriction , KBA , templates , access restrictions , write access , create , create button , no access , LOD-CRM-SC-SM , Social Media , How To
Product
SAP Cloud for Customer add-ins all versions