SAP Knowledge Base Article - Public

2356282 - Outbound SMS Error "The gateway returned an error while sending the message HTTP Code 400."

Symptom

You have configured the SMS outbound configuration, however when trying to send an SMS from a ticket, error message "The gateway returned an error while sending the message HTTP Code 400." is thrown.

Environment

SAP Cloud for Customer.

Reproducing the Issue

  1. Go to the Administrator work center.
  2. Go to the Business Flexibility view.
  3. Go to the Mashup Web Services.
  4. Select and Edit the service ID 123 (123 represents the web service ID).
  5. You have used hashtags to map mobile phone number [#PHONE_NUMBERS] and sms message body [#MESSAGE].
  6. However, when trying to send an SMS from a ticket, error message "The gateway returned an error while sending the message HTTP Code 400." is thrown.

Cause

The configuration is not correct.

Resolution

The SMS mashup needs to be an HTTP POST with XML body. If the configuration is maintained differently, the scenario will not work, since the placeholder replacement can only happen from an XML body.

  1. Go to the Administrator work center.
  2. Go to the Business Flexibility view.
  3. Go to the Mashup Web Services
  4. Select and Edit the service ID 123 (123 represents the web service ID).
  5. Select HTTP Method as Post and use XML payload / body.

Keywords

sms, configuration, post, http method, outbound, http code 400 , KBA , LOD-CRM-SC-MES , Messaging / SMS , How To

Product

SAP Cloud for Customer add-ins all versions