Symptom
You get error message when trying to access SAP Jam: "Failed to fetch oauth token from gateway".
Environment
SAP Cloud for Customer
Reproducing the Issue
Prerequisite: You have completed the integration of SAP Cloud for Customer with SAP Jam.
- Logon to the SAP Cloud for Customer.
- Go to the Feeds work center.
- You get error message: "Failed to fetch oauth token from gateway".
Cause
Incorrect IDP ID has been added at SAP Jam Admin page.
Resolution
- Go to the Business Configuration work center.
- Go to the Implementation Projects view.
- Select the relevant project & select Open Activity List.
- Go to the Fine Tune step.
- Search and open the activity SAP Jam Integration.
- Check the Local IDP ID under Client Information.
- Log on to SAP Jam.
- Go to the SAP Jam Admin Page.
- Select Integration.
- Select SAML Trusted IDPs.
- Choose Register your identity provider.
- Change IDP ID as maintained in the SAP Jam Integration activity in Business Configuration.
- Save.
Keywords
JAM, integration, IDP ID, oauth, token , KBA , LOD-CRM-IN-JAM , JAM Integration with Cloud for Customer , How To
Product
SAP Cloud for Customer add-ins all versions