SAP Knowledge Base Article - Public

2357191 - Error in SAP Jam Integration "Failed to fetch oauth token from gateway"

Symptom

You get error message when trying to access SAP Jam: "Failed to fetch oauth token from gateway".

Environment

SAP Cloud for Customer

Reproducing the Issue

Prerequisite: You have completed the integration of SAP Cloud for Customer with SAP Jam.

  1. Logon to the SAP Cloud for Customer.
  2. Go to the Feeds work center.
  3. You get error message: "Failed to fetch oauth token from gateway".

Cause

Incorrect IDP ID has been added at SAP Jam Admin page.

Resolution

  1. Go to the Business Configuration work center.
  2. Go to the Implementation Projects view.
  3. Select the relevant project & select Open Activity List.
  4. Go to the Fine Tune step.
  5. Search and open the activity SAP Jam Integration.
  6. Check the Local IDP ID under Client Information.
  7. Log  on to SAP Jam.
  8. Go to the SAP Jam Admin Page.
  9. Select Integration.
  10. Select SAML Trusted IDPs.
  11. Choose Register your identity provider.
  12. Change IDP ID as maintained in the SAP Jam Integration activity in Business Configuration.
  13. Save.

Keywords

JAM, integration, IDP ID, oauth, token , KBA , LOD-CRM-IN-JAM , JAM Integration with Cloud for Customer , How To

Product

SAP Cloud for Customer add-ins all versions