Symptom
You get a 404 Error when you try to access opportunity from JAM group.
Reproducing the Issue
- Login to the SAP JAM system.
- Go to the group XYZ where you have been invited (XYZ represents the ID of the JAM group).
- Try to access opportunity ABC from the JAM group.
- You get a 404 error.
Cause
Your user does not have access to Opportunity view in SAP Hybris Cloud for Customer.
Resolution
- Login to the Silverlight UI of the SAP Hybris Cloud for Customer.
- Go to the Application and User management work center.
- Go the Business Users view.
- Select the user DEF (DEF represents the business user who is unable to access opportunity from the JAM group).
- Select Edit - Access Rights.
- Go to the Access Restrictions tab.
- Search for the COD_OPPORTUNITY_WCVIEW -> You can find the user does not have access for Opportunities.
- Add the required access for the user (e.g. Unrestricted Right access).
- Save the changes.
Now try to access the opportunity from the JAM group.
Keywords
KBA , LOD-CRM , Cloud for Customer , How To
Product
SAP Cloud for Customer core applications 1708 ; SAP Cloud for Customer core applications 1711 ; SAP Hybris Cloud for Customer add-ins 1708 ; SAP Hybris Cloud for Customer add-ins 1711