Symptom
When trying to Add a New Employee we are getting a System Error.
If we submit the New Hire with Payment Information it gives a system/script error, but works very well if we delete the Payment Information details before submitting.
Environment
Employee central New hire page
Payment information
Reproducing the Issue
Submit a new hire with its respective payment informaton details.
1. Login into application as admin
2. navigate to Admin tools-->Add new employee.
3. enter all the data and navigate to compinfo and enter paymentinfo details and click on Submit
4. observe the behavior.
issue: Fails with application Error
Cause
We need to check if there is any country specific field in the payment information portlet, that was entered in the UI.
This issue seems to be happening when Country Specific Fields are entered along with Payment Information.
Observation: When we enter paytype (ex:Main payment method), payment method(ex: Bank Transfer), bank country(USA).
Cause: the Paymentinfo details USA listed in seperate section as soon selecting Bank country USA.
Resolution
You are not supposed to have Conditional Associations for paymentinfodetailUSA object with bankCountryCode (or any field) and value USA, as this is done as part of the Configure UI rules from "Manage Business Configuration" UI for that Payment Information object. Please check the "Configure UI Rules" for this object once and add/save the rules if necessary.
Please remove the conditional association and everything should work fine (including the country specific functionality).
Keywords
payment information error country specific fields new hire payment information conditional association conditional values , KBA , LOD-SF-EC-PAY , Payment Information (Bank Information) , Problem