SAP Knowledge Base Article - Public

2360675 - Cannot Set Query For Status Of Campaign On Opportunity

Symptom

You cannot maintain a query for Active Campaigns on an Opportunity.

Reproducing the Issue

  1. Go to the Sales work centre.
  2. Go to the Opportunity view.
  3. Click New.
  4. For the Campaign field click the Value Help.
  5. Click Advanced Filter.
  6. For the Status field, click the + symbol.
  7. Set Options =Equal to Value = Active.
  8. Check the box But Exclude.
  9. Set Options = Equal to Value = Finished.
  10. Click OK.
  11. Click Save Query > Rename Query and enter a query name ABC (ABC represents the query name).
  12. Click Apply.

RESULT: the query vanishes.

Cause

This behaviour is as expected.

Resolution

In case of Opportunities the filter is passed for showing the Active and Finished Campaigns by default, as a result of which any further filtering on the set using the Status field won't work.

Keywords

KBA , LOD-CRM-EMP , Employee , How To

Product

SAP Cloud for Customer core applications 1708 ; SAP Hybris Cloud for Customer add-ins 1708