Symptom
The supplier's address was duplicated after the Supplier Migration process.
Environment
SAP Business ByDesign
Reproducing the Issue
- Migrate the suppliers using the Migration of Supplier activity.
- Access the Supplier Base work center and select the Supplier view.
- Select a supplier from the list.
- Click View All in the top right corner.
- Go to the Address tab under Communication.
- You will notice that the address is duplicated, showing both the main address and the duplicate address.
Cause
For the supplier, one entry has been maintained in the Addresses tab of the migration template, which has a time zone of UTC+1.
In the Contacts tab, contact persons have been entered with business addresses, where the time zone is noted as UTC+01 (please note the difference between these two time zone entries).
The program logic compares the addresses in the Addresses tab with the business addresses maintained for the contacts. If the addresses are identical, only one entry will be created. The comparison is based on the following fields:
- COUNTRY
- HOUSE_NUMBER
- STREET (multiple entries)
- CITY
- REGION_STATE
- POSTAL_ZIP_CODE
- DISTRICT
- TIME_ZONE
In this example, since the time zones do not match, a second address is created. The value codes for the two time zones are different, leading the logic to determine that the addresses are not equal, which results in the creation of a second address line. This differentiation is technically necessary.
Resolution
It is essential to use identical time zones in the addresses within the Migration of Supplier template.
Keywords
Migration of Supplier, Timezone, AddressDuplicated , KBA , AP-BP-BPT , Business Partner Template , How To