SAP Knowledge Base Article - Public

2365709 - Competency behaviors order changed in the Completed form - Performance Management

Symptom

When the form is in Modify stage, competency behaviors display in alphabetical order or as defined in Manage Competencies (JDM), but once the form is completed, the competency behaviors are no longer in order.

Environment

SAP SuccessFactors Performance Management

Reproducing the Issue

  1. Launch a PM form where competencies have mapped behaviors.
  2. Observe that the behaviors populated in the form is in the correct order during Modify stage.
  3. Route the form to completion and notice that the behavior order changes.

Cause

The reason why the competency behaviors are sorted in a different order is because the lock-behavior-content="false" was configured in the template.

Resolution

Before form completion, the system pulls the behaviors dynamically and they are not stored in the form content. In this status, these behavior items are ordered by default.

Once the form is completed, the system pulls the behaviors from the competency library and stores them in the form content. At this time, the order is following the competency library.

To retain the behavior order, set the lock-behavior-content="true". With this setting, behavior content is locked at the form creation. Even though behaviors are changed in the library, it won't be changed on the form.

Keywords

behavior order, completed form, competency behavior order , KBA , csg_q , LOD-SF-PM-FAM , Competencies Behaviors Families and Roles , Problem

Product

SAP SuccessFactors Performance & Goals all versions