SAP Knowledge Base Article - Public

2367135 - Access Restriction for Account is not Working on Live Activity

Symptom

Access Restriction for Account is not wworking on Live Activity.

Reproducing the Issue

  1. Login to HTML UI with a user who is not authorized (both Read and Write) for Accounts.
  2. Open the Live Activity from right pane.
  3. Simulate a call for the phone number of account XYZ using CTI Adaptor (XYZ represents the ID of the account to which user does not have access),
  4. In Live Activity screen the caller has been recognized as XYZ.

Your expectation is that the caller should not get recognized for the user as she does not have access for the account.

Cause

In the Live Activity, if the user receives a call from a customer for which she is not autorized, the system will recognize the caller but in this case:
- on mouse over, no information of account will apear for the user.
- the user will not be able to open the account by clicking on the account name.

The account details will only be available if user has access to that particular account.

Resolution

This is the expected behavior of SAP Hybris Cloud for Customer.

Keywords

KBA , LOD-CRM-LA , Live Activity , How To

Product

SAP Cloud for Customer core applications 1708 ; SAP Hybris Cloud for Customer add-ins 1605 ; SAP Hybris Cloud for Customer add-ins 1608 ; SAP Hybris Cloud for Customer add-ins 1611 ; SAP Hybris Cloud for Customer add-ins 1702 ; SAP Hybris Cloud for Customer add-ins 1708