Symptom
Access Restriction for Account is not wworking on Live Activity.
Reproducing the Issue
- Login to HTML UI with a user who is not authorized (both Read and Write) for Accounts.
- Open the Live Activity from right pane.
- Simulate a call for the phone number of account XYZ using CTI Adaptor (XYZ represents the ID of the account to which user does not have access),
- In Live Activity screen the caller has been recognized as XYZ.
Your expectation is that the caller should not get recognized for the user as she does not have access for the account.
Cause
In the Live Activity, if the user receives a call from a customer for which she is not autorized, the system will recognize the caller but in this case:
- on mouse over, no information of account will apear for the user.
- the user will not be able to open the account by clicking on the account name.
The account details will only be available if user has access to that particular account.
Resolution
This is the expected behavior of SAP Hybris Cloud for Customer.
Keywords
KBA , LOD-CRM-LA , Live Activity , How To