SAP Knowledge Base Article - Public

2367408 - In the Sales Order you get the Option 'Submit for Approval' Though the Approval Process has not been Created for the Sales Order

Symptom

In the sales order you get the option Submit for Approval though the Approval Process has not been created for the sales order.

Environment

  • SAP Business ByDesign
  • SAP Cloud for Customer 

Reproducing the Issue

  1. Go to the Sales work center.
  2. Go to the Sales Order tab.
  3. Open the sales order XYZ (XYZ represents the ID of the sales order).
  4. Select Actions -> the option Set as Complete is grayed out.
  5. Select Actions -> Choose the action Submit for Approval.
  6. Now the action Set as Complete is available for selection.

You are expecting the action Set as Complete to be available without selecting Submit for Approval.

Cause

The current system behavior is that if you have scoped Multi-step Approval Process for the sales order, then the sales order cannot be Set as Complete without clicking Submit for Approval option (regardless of approval process defined or not defined in the Application and User Management work center).

Resolution

If you want a change in the behavior, please raise it as a new requirement from via the link provided in the KBA 2531650 - New Customer Request for Additional Feature or Function in SAP standard software

See Also

Keywords

 no approval process, , KBA , sales order , no approval process , AP-SLO , Sales Order Processing , How To

Product

SAP Business ByDesign all versions ; SAP Cloud for Customer core applications 1705 ; SAP Cloud for Customer core applications 1708 ; SAP Hybris Cloud for Customer add-ins 1705 ; SAP Hybris Cloud for Customer add-ins 1708