SAP Knowledge Base Article - Public

2367937 - Job History Import Error: Failed to perform country specific validation - Employee Central

Symptom

  • While trying to import data into Employee Central for Job History, the system shows the following error message.
  • [Failed to perform country specific validation. Please ensure this record is associated with a valid Company record for given dates.]

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP Successfactors Employee Central

Reproducing the Issue

  1. Navigate to Admin Center
  2. Import employee data
  3. Import Job History (Incremental/Full Purge) 
  4. See the error below:

1.JPG

Cause

The issue/error may occur for the several different reasons. Commonly:

  • When the country cannot be determined for some of the records
    • Even if a single record fails in fetching the country, whole import file fails
    • Country specific fields are validated and populated based on the country
  • Missing legal entity views
    • With the assistance of your Implementation Parter, disable and reenable EC v2 from Provisioning to recreate the missing views for this instance
    • Once the missing view is available, you should not see the reported error message

  • Inactive legal entity: in case the Legal Entity is inactive, even if you try to perform a backdated change, system will throw the error

Note: Legal entity views can also be regenerated via the UI. Follow the Resolution below

Resolution

  1. Go to Admin Center or Home > select Reports
  2. Choose Analytics
  3. Click on Ad Hoc Reports > Create New Report
  4. Select Report type > Single Domain Report and Report Definition type > Foundation Objects
  5. Choose Create
  6. Click on Columns > Select Columns > On the left: Legal Entity > On the right: start-date
  7. Click Done > Preview
  8. This will generate missing views for legal entity due to which error existed

To check and confirm the effective start date of legal entity which you have used for the records having error:

  1. Try to create a new legal entity and then import records using it
  2. Check if the error exists. This will confirm if the issue is due to legal entity

Note: An incorrect date format for the start-date field in job info import csv (defaulting to the default locale of the user) can also cause errors. Please have a look at date formatting.

Performing changes to inactive legal entities, to records associated with inactive legal entities or creating backdated records associated with inactive legal entities are currently not supported.

This is the expected behavior.

Keywords

SF, success factors, EC, Country specific validation fails, import country validation, valid country record, number of failed records , KBA , LOD-SF-EC-JOB , Job Information , LOD-SF-EC-EDP , Import Employee Data (EC Core only) , Problem

Product

SAP SuccessFactors Employee Central all versions