Symptom
The Skillsoft Connector Job is failing with the following error:
Error 9902 The Skillsoft Component does not exist in LMS. Hence rejecting the Component - Curricula Mapping Record
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Learning Management System
Reproducing the Issue
- Run the Skillsoft Connector scheduled job.
- Check the error logs: System Admin > Connectors > Skillsoft Connector > View Results > View Details
Cause
Unfortunately, this error msg can be thrown in different scenari: we are working with our developers to improve this.
- The default value of the subject area field in the Skillsoft Connector configuration is not the same as the value in the input file. Thus the input data is rejected.
- The item is not included in the input file
Resolution
The default value of the subject area field in the Skillsoft Connector configuration is not the same as the value in the input file
- Check the error logs: Entity ID column.
In this screenshot, the Subject Area in the input file is "Course":
- Check the Skillsoft Configuration: System Admin > Configuration > Connectors
- Search for skillsoft.skillsoftsubjectarea.field.transform.data.CPNT_TYP_ID.@DEFAULT@=
In this screenshot, the default value of the subject area is ONLINE:
4. Modify the Skillsoft Connector Configuration to reflect the same value as the input file. (e.g. If the configuration is set to "ONLINE", then the input file must also have the subject area value = "ONLINE")
The item is not inlcuded in the input file:
Note that the error msg states: "The item does not exist in LMS" however this should not be an issue since the connector is meant to import items in LMS. But it could be that the customer_Catalog_input file is missing or empty and in that case the error message makes sense.
Resolution: consult Skillsoft support to understand why the input file is missing or empty and re run the connector once this is fixed.
But in the case where the files are there and contain data:
1. Take one of the items from the "view results" report and search for it in both input files (customer_catalog and customer_catalog_subject_area), you might not be able to find it in customer_catalog.
2. You can verify with Skillsoft support and they will confirm what type of extract the LMS is requesting (i.e a full file or delta file).
Check this configuration (LMS admin > system admin > configuration > > system configurationconnectors > skillsoft.item.connector.initiation_mode= if it is set to
ALL, then the connector is expecting a full file. DELTA, then the connector should not be expecting the full file which explains why you could not find some records in the customer_Catalog file.
We had a case where the value was FULL instead of ALL and the connector was requesting a DELTA file to skillsoft and throwing this 9902 error which did not make any sense.
Resolution: change configuration value from FULL to ALL and re run the connector
Keywords
SAP, SF, Success Factors, learning, Skillsoft Connectors, Error 9902, configuration, Subject Area, default, LMS , KBA , LOD-SF-LMS-CON , Connectors , Problem