Symptom
This KBA explains the root cause for the problem and how to update the translatable fields and which version of the iFlow supports the same.
Environment
BizX,Boomi
Reproducing the Issue
1. Trigger the replication of the iFlow by sending a Idoc from ECC
2. In this scenario, let's try to update the translation for description.
Before Upsert:
3. Following is sent in the payload:
<?xml version="1.0" encoding="UTF-8"?> <FO_costCenter> <externalCode>000050</externalCode> <end_date>9999-12-31</end_date> <start_date>2016-01-01</start_date> <status>Active</status> <costcenterExternalObjectID>000050</costcenterExternalObjectID> <name_en_US>ANNUITIES CRO</name_en_US>
<description_en_US>ANNUITIES CRO</description_en_US>
</FO_costCenter>
After Upsert:
Cause
The root cause is in the version of the iFlow used.
1308 release of cost center iFlow does not pick up the the translatable fields in accordance with the language defined in the ERP.
Resolution
The solution for this problem is in V2.0 Of Cost Center iFlow.
This iFlow is designed to fill in the value of translations in accordance with the default language from ERP end.
Keywords
KBA , LOD-SF-INT-BOM , Standard SF to 3rd Party Boomi Content , LOD-SF-INT-API , API & Adhoc API Framework , Problem