Symptom
Some fields are not visibly available in the "Add New Item" window.
Environment
LMS
Reproducing the Issue
Go to System Admin --> Learning Tab --> Items --> Click on "Add New"
Notice that the first screenshot below does not have "Approval date" as compared to the second screenshot.
FIRST SCREENSHOT: SECOND SCREENSHOT:
Cause
Some of the fields are not marked as "Required" in the Record Configuration section.
Resolution
Go to System Admin --> Configuration --> Record Configuration
1.) Select "Item" as the Record to be configured --> Look for the field that you want to add (in this case I used "Approval Date") --> Click Add (See screenshot):
2.) Once added on the Display Section, search for your newly added field and check/tick the box beside it to set it as "Required" --> Click on Save (See screenshot):
3.) Now when you go back to the "Add New Item" window, you should be able to see "Approval Date" in there.
Keywords
Add New Item, Add New Item Field, Record Configuration, New Item, Item, Required field , KBA , LOD-SF-LMS , Learning Management System , How To