SAP Knowledge Base Article - Public

2372583 - PDI Extension Field is not Visible for Particular Employee or Documents

Symptom

You have created an extension field in your PDI solution and extended to Employee screen, but the field is not visible for some employees.

Environment

  • SAP Cloud Applications Studio
  • SAP Cloud for Customer
  • SAP Business ByDesign

Reproducing the Issue

  1. Login to UI.
  2. Navigate to the Personnel Administration work center.
  3. Select Employees View.
  4. Open an Employee's record.
  5. The extension field is missing.

Cause

You have assigned a restriction for the particular employee in the UI Designer in viewing the extension fields from a particular section.

Visibility.PNG

Resolution

If you want to make the extension field visible for the particular employee then you have to remove the restriction. You can follow the below steps:

  1. Navigate to the UI designer of the screen.
  2. Select the relevant tab where you have added the field.
  3. Select the section in which the extension field belongs to.
  4. Open Extensibility Explorer.
  5. Select the respective entity. from the list.
  6. Click on Change Section Group button.
  7. Corresponding XML will be opened as shown in the image attached above.
  8. You can see that for that particular user the parameter ChangeFieldVisibility fieldModelID is set as True.
  9. You can either set this to false or remove the restriction.

 Note: This scenario can be applicable for documents/ records in different application components.

 

Keywords

Extension field,KUT,Not Visible,Extensibility,True,ChangeFieldVisibility , KBA , pdi extension field , AP-RC-BDS-BO , ByDesign Studio BO definition/generation , How To

Product

SAP Business ByDesign all versions ; SAP Cloud Applications Studio all versions ; SAP Cloud for Customer add-ins all versions