Symptom
You have enabled the approval for manual customer invoice and defined the approval process. However, when you release a manual invoice request, the aprpoval process is not triggerred. The invoice is created and released directly.
Reproducing the Issue
To check the approval process for customer invoices:
- Go to the Application and User Management work center.
- Go to the Approval Processes view.
- Find the active approval process ABC for customer invoice and open it. (ABC represents the name of the approval process)
For example, the condition is set that the Absolute Gross Total Not equal to 0.00 USD.
Work Distribution: Direct Approvers
Employee Responsible: Multiple Approvers are maintained.
Then you create a manual invoice request with total value 400.00 USD, the approval condition is met. You expect the aproval process ABC is triggered and the invoice goes to approval process. However, this invoice is released dirctly with Approval Status as Aprpoval Not Necessary.
Cause
If the user has the access to approve task of Customer Invoice, the release will be successful and no approval task will be triggered meaning that the approval of customer invoice task will be skipped.
Resolution
To check the access rights of the respective user.
- Go to the Application and User Managemant work center.
- Select the Business Users view.
- Find the respective user and click on Edit Access Rights.
- In the tab Work Center and View Assignment, you will see the view MMA_CUSTOMERINVOICING is assigned to the user.
Remove this access rights if you want system triggers the aprpoval process when this user creating a new invoice from a manual invoice request.
Keywords
KBA , approval process for customer invoices , AP-CI-CI , Customer Invoice , How To