Symptom
In "My Classes" unable to send email when there are many number of users.
Environment
SAP SuccessFactors Learning (LMS)
Reproducing the Issue
- As an instructor, Navigate to "My Classes".
- Under Scheduled Classes, you can see the Future classes; select any class with many registrants.
- Navigate to "USERS" tab where choose all registered users or individually selected users can be chosen, then "Send Email".
- Usually after selecting the desired users, when clicked on the "Send Email", the browser opens up the OS configured mail client (e.g.outlook) where all the selected users emailID would be populated in usual as below:
- Now this email functionality doesn't always work or is limited to some users.
Cause
This is due to limitation on browsers using the functionality “mailto” where they have a limitation on the URL length to pass ot the OS.
Hence if the number of characters for the email list increases he browser limitpast t (i.e. by 2,083 chars) then the "mailto" functionality won’t work.
Resolution
Shorten the list while choosing the number of users when trying to send the email from "My Classes".
Keywords
sap, sf, successfactors, success, factors, learning, lms, Send, Email, option, from, My, Classes, instructor, to , KBA , LOD-SF-LMS-INS , Instructors and My Classes , LOD-SF-LMS , Learning Management System , LOD-SF-LMS-SCH , Class - Scheduled Offerings , Problem