SAP Knowledge Base Article - Public

2374800 - Troubleshooting Video Playback of Learning Items

Symptom

This KBA covers troubleshooting the following video playback issues for Learning Items:

  • Videos inside an online item cannot be played/run under Microsoft Edge (Invalid Source)
  • IE is played on Windows Media Player while in Firefox and Chrome they are able to play inside the browser

Environment

SAP SuccessFactors Learning Management System - LMS

Cause

Issues are related to the Browser not related to LMS application

Important Note: Since the below steps involve browser configuration, please be sure to consult with your IT Department to ensure all Security & IT Policies are followed prior to making changes

Resolution

Consult Microsoft Help: https://support.microsoft.com/en-ie/kb/2532294

Work with your IT Department to go through the issue and Microsoft notes in order to resolve the problem:

When you experience problems playing videos in Internet Explorer, these problems may be caused by a number of different issues. Most video playback uses Adobe Flash, Microsoft Silverlight, or Java, and these platforms require Internet Explorer add-ons in order to play. By making sure that you have the latest updates installed for Windows, Internet Explorer, and any Internet Explorer add-ons, you can resolve most video playback problems.

Troubleshooting steps

To troubleshoot video playback problems in Internet Explorer, follow these steps. Test the playback behavior after each step until the issue is resolved.

  1. Update Internet Explorer: Use the latest version of Internet Explorer for your operating system, and then apply any applicable updates that are offered by Windows Update.
  2. Test the video in Compatibility View: Some websites may have been designed for earlier versions of Internet Explorer. Switch to Compatibility View, and then see whether the video plays.
  3. Make sure that add-ons are installed and enabled: Make sure that the necessary add-ons are enabled in Internet Explorer. To do this, follow these steps:
    1. On the Tools menu in Internet Explorer, click Internet Options.
    2. Click the Programs tab, and then click Manage add-ons.
    3. In the Currently loaded add-ons list, click Run without Permissions.
    4. Look for the following add-ons in the list that's displayed. If any of these add-ons are listed, make sure the Status for each is listed as Enabled. •Shockwave Active X Control
      • Shockwave Flash Object
      • Java Plug-in (may be multiple add-ons)
      • QuickTime Plug-in (may be multiple add-ons)
      • Windows Media Player

Keywords

SF Learning play playback Videos in MS Edge IE don't work , KBA , LOD-SF-LMS-COR , LMS Core - Items, Catalog, Curricula , Problem

Product

SAP SuccessFactors Learning 1608