Symptom
Possible causes and steps to correct the issue can be found in this article.
Reproducing the Issue
When trying change the Employee information, using the Admin Center -> Manage Users
The system return a message " Invalid Entry! Enter a valid email id. "
Cause
1. The email id is in fact not valid.
Make sure the address is following the convention. Sample: name@company.com
or
2. Misconfiguration
Max lenght of email field was not configured in the system data model.
Resolution
Possible resolutions based on your configurations are:
- Make sure the address is following the convention. Sample: name@company.com
- Max length of email field was not configured in the system data model.
If you are sure about that the Email-id is valid, please contact your partner or support team to verify.
If you would like to turn off the email validation, please follow these steps:
- Log into the Learning system as an Administrator
- Navigate to System Admin>Configuration>System Configuration>LMS_ADMIN
- Change the following configuration value from 'true' to 'false', thus:
# When emailValidationEnabled is set to true, the class in emailValidationClassName is called to validate e-mail syntax.
# When a user types in an e-mail address, the system checks for @ symbols and periods (.) for correct e-mail syntax. Default: true.
emailValidationEnabled=true
WARNING: This is a global setting, if the emailValidationEnabled property is set to false, Learning will not validate the syntax of any addresses entered in fields where administrators or users can enter e-mail addresses. Double check all email addresses entered are in a valid format to ensure messages are received successfully.
Keywords
invalid email id, user, profile , connector , KBA , LOD-SF-PLT-USR , User Management , Problem