Symptom
You have set up a substitution in the system, for example with employee A being the substitute of employee B (where A and B represent the employee IDs). However when employee A logs into the system and enters the Team Calendar via workcenter Managing My Area, they cannot find employee B (even though the employees who respond to employee B are visible).
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Application and User Management work center.
- Enter the Substitutions view.
- Click on the New button, then click on Substitution.
- Set up a substitution by setting the employee to be substituted, and the employee substitute.
- Click on Save and Close.
- Log in as the substitute employee.
- Go to Managing My Area workcenter.
- Under the Common Tasks section, click on Launch Team Calendar.
Here in the employee list, you are not able to see the employee being substituted.
Cause
The substitution of an Employee does not give authorization to the substitute to see the details of the Employee which is being substituted. Only employees who report to the substituted employee are visible, as the substitute is working on behalf of the employee.
Resolution
The system works as expected.
Keywords
Team Calendar, Substitute, Managing My Area, Task , KBA , SRD-HR-TLM , Time and Labour Management , How To