SAP Knowledge Base Article - Public

2377140 - When Saving Payment Information Field Remains Blank

Symptom

When saving a Payment Information record, a country specific field remains blank/null, such as 'Building Society Roll Number UK' or 'Account Type'.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

Employee Central - Payment Information

Reproducing the Issue

• Edit a Payment Information Record for a user
• Populate all fields with a value
• Save the record
• Particular country specific field remains Null/Blank after saving

Cause

This issue is caused by the wrong trigger of the Buisness Rule "delete_BankDetails_BankCountryChange"

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For Example the rule is triggered as a 'validateRule' on Object Definition 'Payment Information Detail'.
This rule is setting particualr fields to null for all countries.

 

Resolution

The rule "delete_BankDetails_BankCountryChange " should only be triggered as onChange on the bankCountry field on the Object Definition 'Payment Information Detail':

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Keywords

Account Type, Building Society Roll Number, Payment Information Detail, ECT-59485 , KBA , LOD-SF-EC-PAY , Payment Information (Bank Information) , LOD-SF-EC , Employee Central , Problem

Product

SAP SuccessFactors Employee Central all versions