Symptom
Users can't add course in Training Planner, because the “Add Course” button isn't available.
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Learning user side > Access Training Planner >
- Choose any training request period in the upper right dropdown >
- The "Add Course" button isn't available in the bottom of the page.
Cause
There are two possible causes:
- The training request has been reviewed by the Training Manager.
- The training request period doesn't allow planning.
Resolution
Verify if the Training Manager has already reviewed the request:
-
Search for the Training Manager and proxy as him/her or contact the Training Manager >
-
Learning user side > Access Training Planner > My Organization Requests >
-
Verify if the training requests have been reviewed for the organization where users can't see the "Add Course" button >
- Once the budget is reviewed, that team's budget is locked until the Training Manager clicks the "X" to cancel their review.
Verify if planning is allowed in the training request period:
-
Learning Administration > References > Training Planner > Training Request Periods >
-
Access the desired one > Check if the "Allow Planning" box is selected >
-
If not, select it > Click "Apply Changes".
See Also
Keywords
training, planner, add, course, button, missing, request, manager, review, cannot, see, find, organization, view, not, available , KBA , LOD-SF-LMS-TRA , Training Planner , LOD-SF-LMS , Learning Management System , LOD-SF-LMS-USR , User Entity , LOD-SF-LMS-COM , Commerce , Problem