Symptom
Employee received Unable to Rate 'N - Too early or long term absence' in his PM form, but when the manager access the Compensation form he sees Rating = 0 for the same employee.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Manager expects to see 'N - Too early or long term absence'.
Environment
SAP SuccessFactors Compensation
Reproducing the Issue
Compensation has the following Rating Source: Rating is coming from a PM template and both Comp template and PM template use a custom Rating Scale from 0 to 4. That is one of the reason why the manager does not expect Rating = 0 for his direct report.
Cause
The Compensation forms handle 'unrated' and 'Unable to Rate' (in this case, 'N - Too early or long term absence') differently. If PM form is created but not rated, then in compensation form the rating should display as 'unrated'. But if the PM form is created and rating is saved as 'Unable to Rate', then the rating on comp form should display as '0'. This is the expected behavior of the system.
Resolution
Usually customers use Rating Scale from 1 - 5 in order to avoid this kind of situation or change the XML definition to showFormRatingAs="text" instead of showFormRatingAs="number". Then all Ratings would display as text, and not number.
Incident was craeted with Engineering team addressing this question. Support Engineers may refer to the Internal Memo to find the case number.
See Also
Keywords
SuccessFactors, SuccessFactors, SF, compensation, template, templates, form, forms, Rating, 0, Unable to Rate, PM, performance, , KBA , LOD-SF-CMP-FRM , Forms & Templates , Problem