Symptom
The Notes field on the Customer header does not update to the last Note entered in the Notes facet.
Environment
SAP Cloud for Customer
Reproducing the Issue
Prerequisite: You have enabled both the Notes field on the Customer header, as well as the Notes facet.
- Go to the Customer work centre.
- Go to the Accounts view.
- Open any account.
- For the Notes field on the header, enter any free text ABC (ABC represents the free text entered).
- Go to the Notes facet and enter any note DEF.
- Enter a second note GHI within the Notes facet.
Result: The Notes field on the account header does not update to display DEF or GHI -> the Notes field on the account header still shows note ABC.
Cause
The Notes field in the header displays whatever (free) text is entered within that field; however, it corresponds only to the first Note entered within the Notes facet.
When you add the first Note in the Notes Facet of an Account - this will populate in the Notes field in the Account Header in the Overview Facet.
When you add any further Note(s) in the Notes Facet of an Account - those will not replace the text that got populated in the Notes field of the Account Header in the first round, but will be create second note in the Notes facet.
Resolution
We advise not to show the free Text field in the Header, when the Notes facet is being used.
If the aim is to be able to create some free Text for Accounts, use the field in the header. However, if the requirement is to create several (ongoing) notes, the Notes facet should be used.
However, to replace the first Note in the Account header, you can add the note directly in the Account header and it will be added with the new time stamp.
You can still view all the notes in order in the Notes Facet.
Keywords
note, notes facet, header, notes, account overview. , KBA , account , header , notes , notes facet , LOD-CRM-ACC , Account , How To