SAP Knowledge Base Article - Public

2381347 - Lead Auto Assignment does not Work

Symptom

A rule to assign all Lead transactions to a custom party role does not work.

Reproducing the Issue

  1. Go to the Administrator Work Center.
  2. Select the Sales and Campaigns view.
  3. Click on Defined Rules for Lead Assignment.
  4. Add a rule to assign all Lead transactions to one user ABC (ABC represents the user's name).
  5. Go to the Sales Work Center.
  6. Go to the Leads view.
  7. Create a new Lead by clicking the new button on the right.
  8. Select an Account for which ABC is not the owner.
  9. In the new Lead the owner of the Lead is the owner of the Account.

Cause

The Owner in a Lead cannot be mapped to a custom role. This is always linked to the Employee Responsible role in the Lead Party Fine Tuning (Business Configuration > Fine Tuning Activity -> Lead -> Maintain Invoved Parties).

Resolution

This is the system standard behavior.

Keywords

KBA , LOD-CRM-WKF , Workflow , How To

Product

SAP Cloud for Customer core applications all versions ; SAP Hybris Cloud for Customer add-ins 1708 ; SAP Hybris Cloud for Customer add-ins 1711