Symptom
The save gets rejected with the error no change detected: save not executed when adding a new Marketing Attribute to a Contact.
Reproducing the Issue
Prerequisite: A Contact ABC (ABC represents the name) which already has a Marketing Attribute 123 (123 represents the name) which has the Attribute X1 maintained is active in the system.
- Go to the Customers work centre.
- Go to the Contacts view.
- Open the Contact ABC.
- Go to the Marketing Attributes facet.
- Click Edit.
- Click Add and select a new relevant Marketing Attribute 456, which also contains X1.
- Click Save.
Result: The save is rejected with the error: no change detected: save not executed.
Cause
This issue can occur in some cases when the same Attribute is being linked via two different sets.
For the Contact ABC there is already the set 123 which has the Attribute X1 with an assigned value .
Now, when you include the set 345, it has the same attribute X1.
When an attribute is linked to different sets, then when it is included in a Business Partner, only one value can be entered.
Since that is already maintained with the set ABC the new value is not recognized.
Resolution
1. Create a separate Attribute with a different Attribute ID but the same description & drop down values as X1.
2. Include this in the set DEF instead of the other attribute.
This should solve the problem
Keywords
KBA , SRD-CC-FED , Feeds , How To