SAP Knowledge Base Article - Public

2383365 - Slow performance when refreshing a report based off Salesforce.com in Crystal Reports

Symptom

  • Slow to refresh.
  • Takes time to refresh a report based on Salesforce.com
  • Error: 'INVALID_QUERY_LOCATOR', when refreshing a report based off Salesforce.
  • Slow performance when refreshing a report based off Salesforce.com in Crystal Reports 2013 or 2016.
  • The same report used to refresh quickly in Crystal Reports 2008 and in Crystal Reports 2011.

Environment

  • SAP Crystal Reports 2013
  • SAP Crystal Reports 2016
       
  • Salesforce.com

Reproducing the Issue

  1. In Crystal Reports, create a report off Salesforce.com
  2. Add at least 2 tables on the report.
  3. Add a record selection to filter data.
  4. When refreshing the report, it takes more time than expected to retreive the data.

Cause

  • To connect to Salesforce.com, Crystal Reports 2013 and above, uses the embedded SAP Salesforce ODBC driver provided by Simba.
  • The SAP Salesforce ODBC driver does not send the filter added in Crystal Reports to Salesforce, therefore, it will fetch all the data back and filter it on the client side, and this is why the performance is slow.
  • This is a kown issue that have been tracked under SAP Note 2376390

Resolution

  • The issue is resolved in the SAP Salesforce ODBC driver version 1.2 from Simba, which is bundled in the following product updates of Crystal Reports:
                  
    • Crystal Reports 2013
      • Support Pack 09
                
    • Crystal Reports 2016
      • Support Pack 04
             
                  
  • It is also suggested to change the registry key for the batch lookup cache size, after applying the product update to help improve the performance.
        
    WARNING: The following resolution involves editing the registry. Using the Microsoft Registry Editor incorrectly can cause serious problems. Use the Registry Editor at your own risk. For further information see the SAP Knowledge Base Article 1323322
             
    1. Open the Microsoft Registry Editor ( Regedit )
             
    2. In the Microsoft Registry Editor, navigate to the following path:
             
      • For 64 bit version of MS Windows:
              
        HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\SAP BusinessObjects\Suite XI 4.0\Crystal Reports\Database  
            
      • For 32 bit version of MS Windows:
             
        HKEY_LOCAL_MACHINE\SOFTWARE\SAP BusinessObjects\Suite XI 4.0\Crystal Reports\Database  
            
        Note: If the end of the path does not exist, add the directory.
                
    3. Add a String Value key: BatchLookupEnabledDrvNames
           
    4. Set the value to: crdb_sforce.dll
              
    5. Add a DWORD key: BatchLookupCacheSizeList
            
    6. Set the value to: 200
             
    7. Restart Crystal Reports.

Keywords

CR, Sforce, saleforce, Sales Force , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Problem

Product

SAP Crystal Reports 2013 ; SAP Crystal Reports 2016