Symptom
The Description field is no longer Mandatory by default from the 1611 release onwards, however, the Key User can set the field as Mandatory via Adaptation mode.
Reproducing the Issue
With a 1611 release system:
- Go to any Ticket creation view (i.e.: Service work centre > Ticket view > click New).
- In the pop up, create a Ticket by entering the mandatory fields.
RESULT: The field Description is no longer mandatory and does not have to be filled.
Cause
This change has been applied with the 1611 release in response to customer demand.
Resolution
To make the field Mandatory, you can go to Adaptation mode on the Ticket Quick Create UI and hover over the field Description, until the Properties icon appears.
1. Click on the Properties icon you can edit the Mandatory check box - > exit Adaptation mode.
2. In some cases the Mandatory check box may appear disabled, in this case select the Rule link next to the Mandatory checkbox option.
3. In the Rule settings UI, don’t add any rule but click the Apply button at the bottom right and the Mandatory field becomes enabled for checking it. Then select the checkbox and exit Adaptation mode.
To set the field as Read Only, follow the above steps but instead of checking the box for Mandatory, check the box for Read Only.
Keywords
KBA , AP-SVO , Service Order Processing , Bug Filed