Symptom
In an object such as a visit or customer you get the following error messages:
'STRUEXIT: Processing of Transformation failed'
'Getting the navigation target name XYZ failed'.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
- Open the effected object (Visit/ Customer/ Opportunity...) from the respective work center.
- You get the above error messages.
Cause
You have embedded a report into this object. While editing it, there was a temporary inconsistecy which now raises the error messages as soon as the embedded report is called.
Resolution
Please remove your embedded report, save and then add it again.
The steps are:
- If we take the visit as an example, go to the Visits work center and open any visit (or navigate to the view where you have the issue).
- In the top right corner of the screen, click on Adapt > Edit Master Layout.
- Use the mouse to hover over the report header.
- A set of buttons appear. Click on X to delete the report.
- Click on Adapt again and leave the adaptation mode.
- Re-enter the adaptation mode.
- Hover at the top of the visit screen until the + button appears. Click on Add Embedded Reports.
- Select your report from the list. Edit the parameter mapping if required and click on Apply.
- Leave the adaptation mode.
Keywords
Adapt, STRUEXIT: Processing of Transformation failed Getting the navigation target name XYZ failed , KBA , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , How To