Symptom
You created a Survey that is used when creating a new Lead/Opportunity. When the Routing Rule is evaluated you expect the Survey to be assigned automatically as indicated in your Activity Plan but during Lead/Opportunity creation you have to add the Survey manually or use the action Update from Activity Plan.
Reproducing the Issue
1) Create a Lead/Opportunity
2) No Survey is assigned automatically - you have to add the Survey manually or use the action Update from Activity Plan.
Cause
Lead and Opportunity do not have automatic assignments for Surveys unless configured by user. Auto Assignment of Surveys needs an addtional step for it be displayed automatically - you should also create the workflow rule to enable the feature.
Resolution
In order to configure automatic assignment, you need to configure a Workflow Rule for action Refresh From Activity Plan. It can be configured for every save/create to ensure that the action is automatically run and the Surveys are assigned.
- Go to Administrator work center
- Choose Workflow Rules view
- Click New
- Choose Business Object as Leads in this example
- Choose the Timing as On Create Only
- Move to Define Actions step
- Choose Rule type as Actions
- Choose action Refresh from Activity Plan
- Choose Activate
- Choose Finish
This will ensure that relevant surveys are added automatically.
Keywords
KBA , AP-BP-BPT , Business Partner Template , How To