SAP Knowledge Base Article - Public

2385040 - Value Help for Owner Field is Empty

Symptom

When trying to add an Employee as Owner by clicking on value help, no results are displayed.

Environment

SAP Cloud for Customer

Reproducing the Issue

This can happen for any Business Object. For example, Opportunities.

  1. Go to Sales > Opportunities.
  2. Click New button.
  3. Select the value help for the Owner field.
  4. No results are shown.

Cause

The affected business user doesn't have access to the Employee view in their access restrictions. Which means the COD_EMPLOYEES is not assigned to the user.

Resolution

In order to see the Employees list results for Owner Organizer, or any other field that will display the Employees results, it is necessary to have COD_EMPLOYEES assigned.

 

The Employees view can be assigned to either the specific business user or the business role.

 

For assigning to the business role, follow the steps below:

  1. Go to Administrator Work Center.
  2. Go to General Settings View.
  3. Open the Business Role hyperlink
  4. Open the Business Role assigned to the user.
  5. Select View All.
  6. Go to facet WorkCenter and View Assignments.
  7. Assign the COD_EMPLOYEES.
  8. Go to facet Access Restriction.
  9. Here ensure that the view COD_EMPLOYEES is assigned and the same is allowed to the users correctly with the right read and write access.

 

For the business user only, please follow:

  1. Go to Administrator Work Center.
  2. Click on Business Users WoC.
  3. Search for the affected user.
  4. Select it and click on edit > edit access rights.
  5. Go to facet WorkCenter and View Assignments.
  6. Assign the COD_EMPLOYEES.
  7. Go to facet Access Restriction.
  8. Here ensure that the view COD_EMPLOYEES is assigned and the same is allowed to the users correctly with the right read and write access.

 

Please note the WorkCenter CODPEOPLE needs to be assigned and then assign only the COD_EMPLOYEES view.

 

Keywords

Lead, Opportunity, Sales Order, Sales Quote, Visits, Routes, Routing Rules, Ticket , KBA , LOD-CRM-EMP , Employee , LOD-CRM-ACC , Account , LOD-CRM-LM , Lead Management , LOD-CRM-ACT , Activities , LOD-CRM-OPP , Opportunity Management , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions