Symptom
When you run the SF Competency Connector and you receive the following error: "Entity does not exist.DomainID:"
Environment
SuccessFactors Learning Management System (LMS) - All Supported Versions
Reproducing the Issue
- Export the competency library you desire from BizX (set up in provisioning)
- Run the SF Competency Connector
- Interface report contains error mentioned above for one or more rows
Cause
This means that the Domain ID as specified in the property: "competency.connector.defaultValue.domainID=" does not exist in the LMS.
Resolution
This can be avoided by making sure the following connector property is referencing an existing Domain ID in the LMS:
competency.connector.defaultValue.domainID=
Where domainID is a pre-existing reference Domain in the LMS.
Please note that existing Domains/Domain IDs can be viewed and new Domains added by navigating to 'System Admin > Security > Domains' in the LMS.
See Also
2185279 - LMS: Troubleshooting tips for competency connector in LMS
2386941 - Avoiding issues with Rating Scales when importing Competencies into LMS
Keywords
LMS; Connectors; Competencies; SF Competency Connector; Domains; Domain ID; competency.connector.defaultValue; , KBA , LOD-SF-LMS-CON , Connectors , LOD-SF-LMS , Learning Management System , Problem
SAP Knowledge Base Article - Public