Symptom
Boomi processes are failing with the following:
Failed to connect to host: sftpX.successfactors.com on port 22. Exception message is: Auth fail; Caused by: Auth fail
Environment
Boomi Platform
SFTP
Cause
There can be several reason for this failure:
- When SFTP credentials (Company ID, Username, Password) are not properly maintained on the Boomi connectors via Environment Extensions.
- If authentication fails at server level inspite of correct credential maintained.
Resolution
1. In order to resolve the credential issue, kindly follow the steps below:
- Ensure to have the correct SFTP credentials by logging in to the SFTP host URL.
- Re-maintain the correct credentials on Boomi via Environment Extension on which the process is deployed.
- Save the changes and retrigger the process.
2. In order to resolve server authentication issue, create an case with complete error log which gives below information:
- Complete error message with timestamp information
- SFTP account detail
- SF Company ID
See Also
SFTP Public IP Addresses and URL's for Data Centres:
https://launchpad.support.sap.com/#/notes/2250792
Keywords
Boomi Auth Fail Failed to connect to host , KBA , LOD-SF-INT , Integrations , Problem