Symptom
The calendar view of schedule offering shows the SO is available for all the days between non consecutive start date and end date, even though the segment is available only on start date and end date.
Example : Scheduled offering with start date November 9th and end date November 16th. By clicking on calendar view the scheduled offering ID appears in all the days from November 9th to November 16th. However the scheduled offering has only 2 segments, one is on November 9th and the other on November 16th.
Environment
SuccessFactors Learning
Learning Management System
Reproducing the Issue
Create an Instructor Led Item with 2 Segments
Create a Schedule offering for this Item with One Segment occuring on a particular date and the other segment at a later date and not on the immediate consecutive date as of the first segment.
Check the calendar view of this offering, It will show the Schedule offering occuring on all days starting from the first segment till the last segment date.
For example, create a SO with start date 13th July. The corresponding ILT has 2 segments. Therefore the created SO will have the first segment on 13th July and second segment on 18th july.
Edit the second segment to occur on a later date instead of 14th July , say for example 18th July. Now the SO has first segment on 13th July, second segment on 18th July.
The calendar View of the SO on the admin side shows as below:
Cause
When the SO is created, we have an option to enter only the start date. Therefore the End date is calculated automatically based on the number of segments in the ILT and the date of the last segment.
Therefore, if we modify the segment to occur on a later date instead of the immediate consecutive date, the end date moves to the future and hence the admin side view of the calendar shows the Schedule offering for all the days.
Resolution
This is working as designed.
Keywords
Calendar View, Schedule offering , KBA , LOD-SF-LMS , Learning Management System , Problem