Symptom
The field configured in the succession data model for the instance is removed later because of some business scenario.
But you still see this field in the CompoundEmployee API response.
Environment
Successfactors System
Cause
The field is deleted from the UI, but the data for the field is still present in the database for the same. Hence, it is returned in theCompoundEmployee response
Resolution
Please use the SFAPI parameter resultOptions = configuredOnlyFields in the CompoundEmployee API request to restrict the response only for the configured fields in the instance.
Example:
<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/" xmlns="http://schemas.xmlsoap.org/soap/envelope/">
<SOAP-ENV:Header />
<SOAP-ENV:Body>
<query xmlns="urn:sfobject.sfapi.successfactors.com">
<queryString>SELECT person,personal_information,employment_information,emergency_contact_primary,dependent_information,associated_employee_information FROM CompoundEmployee</queryString>
<param>
<name>resultOptions</name>
<value>configuredFieldsOnly</value>
</param>
</query>
</SOAP-ENV:Body>
</SOAP-ENV:Envelope>
Keywords
KBA , compound employee api , configuredfieldsonly , fields not configured coming in compound , LOD-SF-INT-API , API & Adhoc API Framework , LOD-SF-INT-BOM , Standard SF to 3rd Party Boomi Content , Problem