Symptom
Picklist field showing incorrect values in the dropdown menu on job requisition page
Environment
SuccessFactors BizX - Recruiting Management(RCM)
Reproducing the Issue
1. Login to instance
2. Navigate to Recruiting dropdown menu showing incorrect values. It is not showing values based on picklist ID mapped to a field in the job requisition template.
For example: Legal entity is a filter field in the job requisition where picklist id associated is "LegalEntity". According to this configuration, system should show values in the drop down with respect to picklist ID "LegalEntity". However, the dropdown shows completely different values.
Cause
Mismatch of picklist ID used in the field in job requsition template and picklist ID used under Internal and External search settings in Provisioning.
Resolution
1. Even though the correct picklist ID used for a picklist field (filter and mfields) in the job requsition XML template, if pickist ID used for that particular field is different under Internal and External Search settings, the system will pull the values in the field's drop down menu based on picklist ID used in Internal and Extrenal Search settings. It overrides the picklist ID used in the definition of the field in XML template.
2. If you are a Partner, you can correct the picklist ID under Internal and External Search settings in Provisioning
3. If you are a Customer, please raise a case with Customer Support to check if correct picklist ID is used in this setting in Provisioning
Keywords
Picklist field; Picklist field showing incorrect values; Job requisition field drop down value , KBA , LOD-SF-RCM-JOB , Job Postings & Requisitions , Problem